About

Program Version :
Execute ITTS and see more detail in menu-->about (pull down menu).
ITTS.chm describe how to execute itts.exe and scrip file
ScripCommand.CHM describe how to create test scrip file.
ScripEditor.CHM explain how scrip editor work
Name: Vincent Cheng
Phone (+886) 963-080987
Email: tw_vincent_cheng@intretech.com (vincentcheng2116@gmail.com)
Name: 傅伟平 Sam Fu
Phone +86-15980826702
Email: Sam_Fu@intretech.com

Neme: Neo Hsieh
Phone Email: tw_neo_hsieh@intretech.com


Contents
About
Menu Function
Hot Key & Debug Mode
PC hardware Information
Start Up
View or Edit Scrip file
ITTS.exe_parameter_string.htm
Debug Mode
Hot_Key_Debug_mode.htm
Trace variable
Log process test result
Scrip file Instruction List
Scrip file Instrction List
ASCII Table
Gesture


GTS.exe parameter string

ITTS.exe parameter string
ITTS can bring with some parameter for user easier to use.
if debug or engineer then ITTS will disable operator mode
if run then ITTS will run test plan automatically after load test plan
if KEEPMINIMIZE ITTS enable KEEPMINIMIZE mode.
keep minimize let engineer run test plan on background ITTS will not interference engineer doing another job.
if exit then ITTS will run test plan automatically after load test plan and then exit ITTS
if OLD ITTS enable old style compatible mode ( will obsolete this feature in the future)
if Turbo ITTS enable old style compatible mode ( will obsolete this feature in the future)
example:
On run dialog box: ITTS.exe debug run exit "test_plan_Name.tpw"
ITTS will run test_plan_name.tpw automatically under engineer mode, exit ITTS once finish test


Hot Key & Debug mode

mode select
Ctrl+ Alt+E cycling
MP ( mass production ) mode
Operator Mode
Engineer Mode

Engineer mode: you will have :
More info/ status show on status list box.
Allow you to access other page ( PIS/ Test / GPIB / RS-232 / Wave Form....) to try or debug your system
Press Ctrl-Alt-E to switch different mode
Under ITTS.exe or Scrip Editor form,
Press following key will effect:
F1: Help
F5: Trace variable
F6 : To see test result field or go to specific test item
if current focus on:
ITTS PIS page:
Press F6 (or double click the specific field), ITTS will go to Test plan and focus on test item which generate the result field.
TestPlanEditor From:
Press F6, It will jump to ITTS PIS page and focus on test result field. related link:PIS test result

F7 : Run this line and stay on current test item.
F8 : Run this line and stay on next test item.
F9 : Run from this Line until end.
F10: go back to ITTS (Switch in between ITTS and TestplanEditor)
Ctrl+F10: Close Test plan Editror form.
F11: Run Initiation group only
Ctrl+1 ~ 5 :Run test items from bookmark 1~5.
ALt+1 ~ 5 :Focus on bookmark 1~5.
Please refer to TESTPLANCOMMAND.HLP
Trigger a signal : with this feature. you could measuer test time between each trigger signal mark. (log in PIS table)
Debug trigger setting:see Test plan command for ( 'Debug' section)
Select Trigger symbol to enable the trigger function. Test program will toggle one pin's status once it recognize
this symbol. it will trigger this pin's status.
ESC: stop testing.
Pause: pause test
Ctrl-Break: Stop monitor "Start Conditions"
Ctrl-Insert: Run "Start Conditions" if exist


PIS test result

Log file Process
Search:
Typing keyword in edit box. ctrl-right arrow or left arrow will help you to search the test result in PIS column.
Measure Time function:
Allow you to record the time stamp every time you have test result in field.
tested time stamp allow you to range select the time stamp area it will calculate the delta time and put it in delta time area.


Menu Function
For more flexibility ITTS has 3 mode could select:
MP mode: Mass production mode, simple UI environment
Operator mode: could check test log. try testability / retestability etc.
Engineer mode: you will have :
More info/ status show on status list box.
Allow you to access other page ( PIS/ Test / GPIB / RS-232 / Wave Form....) to try or debug your system
Press Ctrl-Alt-E to switch different mode
Always on Top
To avoid operator select another application software. check this function will let ITTS always on top
Engineer or test plan developer don't like "Always on top"? ==> just add a string : AlWAYS ON TOP =0 in ITTS.ini ITTS will disable this feature.
Keep Minimize
This function could let engineer run ITTS in back ground.
Load PID information: Load PIS,ini file so that can edit pis.ini setting
Save PID information: Save PIS,ini file
Delete Current CSV(Log) File : Delete Current CSV(Log) File,
Clean Image: Clear Main Form Image.
Clean Table: Clear all Table's data
Clean All: Clean all Table's data & Main Form Image.
Trace Test Status: ITTS will show the status and stay on most updated status line.
Reset: reset ITTS to initial status
Turbo Run:
Checked (Default value): maximum speed to perform the testing
unchecked : use timer interrupt to execute test items. timer could setting on Test page:
Step by Step Debug: To let you debug your test plan item by item.
Run xxxxxx: please see Hot Key / Debug Mode for more detail.
ScripEditor
click ScripEditor to show or hide ScripEditor form. let you edit scrip file.
Widows:
Help
Call Help for more information of Test system and setup instruction.


PC hardware Information
ITTS could record PC Operation System & hardware information in PIS log file,
OS version :
4.10.2222A==>Win98 SE
5.00.2195 ==> Windows 2000 (SP4)
5.1.2600 ==> Windows XP (SP1)
6.1.7601 ==> Winsows7

CPU:
Intel Celeron Intel, x86 Family 6 Model 5
Intel Celeron Intel, x86 Family 6 Model 6
Intel Pentium Pro Intel, x86 Family 6 Model 1
Intel Pentium II Intel, x86 Family 6 Model 3
Intel Pentium II Intel, x86 Family 6 Model 5
Intel Pentium II Intel, x86 Family 6 Model 6
Intel Pentium III Intel, x86 Family 6 Model 7
Intel Mobile Pentium III Intel, x86 Family 6 Model 8
Intel Pentium 4 Intel, x86 Family 15 Model 2
Intel64 Family 6 Model 69 Stepping 1 (Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz)
Example:
CPU: x86 Family 15 Model 2 Stepping 7 (Intel(R) Celeron(R) CPU 2.00GHz)
CPU: x86 Family 15 Model 2 Stepping 7 (Intel(R) Pentium(R) 4 CPU 2.66GHz)
CPU: Intel64 Family 6 Model 69 Stepping 1 (Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz)
Memory Total:
show total memory (RAM) in PC hardware
Memory Available:
show total available memory (RAM) in PC hardware


Test Plan Editor

Scrip Editor & Scrip command:

ScripCommand.chm
ScripEditor.chm
Also could direct click Scrip Editor help ( in ScripEditor' menu -> help)


Start Up
Download and run installation file.
file will put in : C:\program files(x86)\ITTS\ as default (you can change the install directory when install the test program.)
Three ways to run test plan:
1:Double click scrip file (*.itts) or right click on itts file to select the action you want.

2:Run ITTS.exe then load scrip file
ITTS --> ScripEditor --> Load Scrip file


Test plan naming

Scrip file naming
scrip file name xxxx.itts
Compatible with some other test system which write by xml structure


Trace variable
Press F5 or click Tools-> Trace variable to enable the form to trace variable:
click "All Variable" to list down all the variable now ITTS are using.
click "All String Variable" to list down all the string variable now ITTS are using.
click "All ITTS Parameter" to list down all the All ITTS internal Parameter. including share memory,..
double click the check area to enable tracking data of specific variable or smart format
if some of variable or parameter was checked. ITTS will update the data when ever test finish or single step running. if variable value was changed. star area will show "*" for you to easy identification. or you can manual refresh the data by click "Get all Value" [image] or "Get Checked Value"
double click specific variable name will update the value also.
Update When Running:
check this, ITTS will update data in table every test item finished.
(This feature will consume longer testing time!!! )
Pause when data changed
check this, ITTS will monitor variable you selected if data has been changed. ITTS will pause the ITTS test plan Running and wait for your further action.
Pause when data changed also meet the target value
ITTS will pause running only when Target value is matching your desire.
click save icon to save the table as file. in case you need to debug next time.
click Load icon to load a file to table. in case you need to debug again.
"Check all" to check all the variable or parameter in list table.
"Uncheck all" to uncheck all the variable or parameter in list table.
"Delete Unckecked Variable" to erase all the Unchecked Variable.
use insert row icon [image] to insert a row.
use delete row icon [image] to delete a row.
use adjust column with icon [image] to auto adjust column.
you could sort by each column.


View or Edit Test plan

View or Edit Scrip file
Two way to view/edit or execute test plan
1: Use ITTS.exe to load test plan
1.1 Double click *.itts scrip file to execute by ITTS.exe
1.2 Run ITTS.exe then load scrip file form scrip editor
2: Use PITTS_ScripEditor.exe to load scrip file
Right click on test plan select "view by ScripEditor"


ASCII Table

DEC | OCT | HEX | BIN | Symbol | HTML Number | HTML Name | Description |
0 | 000 | 00 | 00000000 | NUL | &#000; | Ctrl-@ | Null char | 空字元（Null）
1 | 001 | 01 | 00000001 | SOH | &#001; | Ctrl-A | Start of Heading | 標題開始
2 | 002 | 02 | 00000010 | STX | &#002; | Ctrl-B | Start of Text | 本文開始
3 | 003 | 03 | 00000011 | ETX | &#003; | Ctrl-C | End of Text | 本文結束
4 | 004 | 04 | 00000100 | EOT | &#004; | Ctrl-D | End of Transmission | 傳輸結束
5 | 005 | 05 | 00000101 | ENQ | &#005; | Ctrl-E | Enquiry | 請求
6 | 006 | 06 | 00000110 | ACK | &#006; | Ctrl-F | Acknowledgment | 確認回應
7 | 007 | 07 | 00000111 | BEL | &#007; | Ctrl-G | Bell | 響鈴
8 | 010 | 08 | 00001000 | BS | &#008; | Ctrl-H | Back Space | 退格
9 | 011 | 09 | 00001001 | HT | &#009; | Ctrl-I | Horizontal Tab | 水平定位符號
10 | 012 | 0A | 00001010 | LF | &#010; | Ctrl-J | Line Feed | 換行鍵
11 | 013 | 0B | 00001011 | VT | &#011; | Ctrl-K | Vertical Tab | 垂直定位符號
12 | 014 | 0C | 00001100 | FF | &#012; | Ctrl-L | Form Feed | 換頁鍵
13 | 015 | 0D | 00001101 | CR | &#013; | Ctrl-M | Carriage Return | Enter鍵
14 | 016 | 0E | 00001110 | SO | &#014; | Ctrl-N | Shift Out / X-On | 取消變換（Shift out）
15 | 017 | 0F | 00001111 | SI | &#015; | Ctrl-O | Shift In / X-Off | 啟用變換（Shift in）
16 | 020 | 10 | 00010000 | DLE | &#016; | Ctrl-P | Data Line Escape | 跳出資料通訊
17 | 021 | 11 | 00010001 | DC1 | &#017; | Ctrl-Q | Device Control 1 (oft. XON) | 裝置控制一（XON 啟用軟體速度控制）
18 | 022 | 12 | 00010010 | DC2 | &#018; | Ctrl-R | Device Control 2 | 裝置控制二
19 | 023 | 13 | 00010011 | DC3 | &#019; | Ctrl-S | Device Control 3 (oft. XOFF) | 裝置控制三（XOFF 停用軟體速度控制）
20 | 024 | 14 | 00010100 | DC4 | &#020; | Ctrl-T | Device Control 4 | 裝置控制四
21 | 025 | 15 | 00010101 | NAK | &#021; | Ctrl-U | Negative Acknowledgement | 確認失敗回應
22 | 026 | 16 | 00010110 | SYN | &#022; | Ctrl-V | Synchronous Idle | 同步用暫停
23 | 027 | 17 | 00010111 | ETB | &#023; | Ctrl-W | End of Transmit Block | 區塊傳輸結束
24 | 030 | 18 | 00011000 | CAN | &#024; | Ctrl-X | Cancel | 取消
25 | 031 | 19 | 00011001 | EM | &#025; | Ctrl-Y | End of Medium | 連線介質中斷
26 | 032 | 1A | 00011010 | SUB | &#026; | Ctrl-Z | Substitute | 替換
27 | 033 | 1B | 00011011 | ESC | &#027; | Ctrl-[ | Escape | 退出鍵
28 | 034 | 1C | 00011100 | FS | &#028; | Ctrl-\ | File Separator | 檔案分割符
29 | 035 | 1D | 00011101 | GS | &#029; | Ctrl-] | Group Separator | 群組分隔符
30 | 036 | 1E | 00011110 | RS | &#030; | Ctrl-Ctrl- | Record Separator | 記錄分隔符
31 | 037 | 1F | 00011111 | US | &#031; | Ctrl-_ | Unit Separator | 單元分隔符

ASCII printable characters (character code 32-127)

Codes 32-127 are common for all the different variations of the ASCII table, they are called printable characters, represent letters, digits, punctuation marks, and a few miscellaneous symbols. You will find almost every character on your keyboard. Character 127 represents the command DEL.

DEC | OCT | HEX | BIN | Symbol | HTML Number | HTML Name | Description
32 | 040 | 20 | 00100000 |  | &#32; |  | Space
33 | 041 | 21 | 00100001 | ! | &#33; |  | Exclamation mark
34 | 042 | 22 | 00100010 | " | &#34; | &quot; | Double quotes (or speech marks)
35 | 043 | 23 | 00100011 | # | &#35; |  | Number
36 | 044 | 24 | 00100100 | $ | &#36; |  | Dollar
37 | 045 | 25 | 00100101 | % | &#37; |  | Procenttecken
38 | 046 | 26 | 00100110 | & | &#38; | &amp; | Ampersand
39 | 047 | 27 | 00100111 | ' | &#39; |  | Single quote
40 | 050 | 28 | 00101000 | ( | &#40; |  | Open parenthesis (or open bracket)
41 | 051 | 29 | 00101001 | ) | &#41; |  | Close parenthesis (or close bracket)
42 | 052 | 2A | 00101010 | * | &#42; |  | Asterisk
43 | 053 | 2B | 00101011 | + | &#43; |  | Plus
44 | 054 | 2C | 00101100 | , | &#44; |  | Comma
45 | 055 | 2D | 00101101 | - | &#45; |  | Hyphen
46 | 056 | 2E | 00101110 | . | &#46; |  | Period, dot or full stop
47 | 057 | 2F | 00101111 | / | &#47; |  | Slash or divide
48 | 060 | 30 | 00110000 | 0 | &#48; |  | Zero
49 | 061 | 31 | 00110001 | 1 | &#49; |  | One
50 | 062 | 32 | 00110010 | 2 | &#50; |  | Two
51 | 063 | 33 | 00110011 | 3 | &#51; |  | Three
52 | 064 | 34 | 00110100 | 4 | &#52; |  | Four
53 | 065 | 35 | 00110101 | 5 | &#53; |  | Five
54 | 066 | 36 | 00110110 | 6 | &#54; |  | Six
55 | 067 | 37 | 00110111 | 7 | &#55; |  | Seven
56 | 070 | 38 | 00111000 | 8 | &#56; |  | Eight
57 | 071 | 39 | 00111001 | 9 | &#57; |  | Nine
58 | 072 | 3A | 00111010 | : | &#58; |  | Colon
59 | 073 | 3B | 00111011 | ; | &#59; |  | Semicolon
60 | 074 | 3C | 00111100 | < | &#60; | &lt; | Less than (or open angled bracket)
61 | 075 | 3D | 00111101 | = | &#61; |  | Equals
62 | 076 | 3E | 00111110 | > | &#62; | &gt; | Greater than (or close angled bracket)
63 | 077 | 3F | 00111111 | ? | &#63; |  | Question mark
64 | 100 | 40 | 01000000 | @ | &#64; |  | At symbol
65 | 101 | 41 | 01000001 | A | &#65; |  | Uppercase A
66 | 102 | 42 | 01000010 | B | &#66; |  | Uppercase B
67 | 103 | 43 | 01000011 | C | &#67; |  | Uppercase C
68 | 104 | 44 | 01000100 | D | &#68; |  | Uppercase D
69 | 105 | 45 | 01000101 | E | &#69; |  | Uppercase E
70 | 106 | 46 | 01000110 | F | &#70; |  | Uppercase F
71 | 107 | 47 | 01000111 | G | &#71; |  | Uppercase G
72 | 110 | 48 | 01001000 | H | &#72; |  | Uppercase H
73 | 111 | 49 | 01001001 | I | &#73; |  | Uppercase I
74 | 112 | 4A | 01001010 | J | &#74; |  | Uppercase J
75 | 113 | 4B | 01001011 | K | &#75; |  | Uppercase K
76 | 114 | 4C | 01001100 | L | &#76; |  | Uppercase L
77 | 115 | 4D | 01001101 | M | &#77; |  | Uppercase M
78 | 116 | 4E | 01001110 | N | &#78; |  | Uppercase N
79 | 117 | 4F | 01001111 | O | &#79; |  | Uppercase O
80 | 120 | 50 | 01010000 | P | &#80; |  | Uppercase P
81 | 121 | 51 | 01010001 | Q | &#81; |  | Uppercase Q
82 | 122 | 52 | 01010010 | R | &#82; |  | Uppercase R
83 | 123 | 53 | 01010011 | S | &#83; |  | Uppercase S
84 | 124 | 54 | 01010100 | T | &#84; |  | Uppercase T
85 | 125 | 55 | 01010101 | U | &#85; |  | Uppercase U
86 | 126 | 56 | 01010110 | V | &#86; |  | Uppercase V
87 | 127 | 57 | 01010111 | W | &#87; |  | Uppercase W
88 | 130 | 58 | 01011000 | X | &#88; |  | Uppercase X
89 | 131 | 59 | 01011001 | Y | &#89; |  | Uppercase Y
90 | 132 | 5A | 01011010 | Z | &#90; |  | Uppercase Z
91 | 133 | 5B | 01011011 | [ | &#91; |  | Opening bracket
92 | 134 | 5C | 01011100 | \ | &#92; |  | Backslash
93 | 135 | 5D | 01011101 | ] | &#93; |  | Closing bracket
94 | 136 | 5E | 01011110 | ^ | &#94; |  | Caret - circumflex
95 | 137 | 5F | 01011111 | _ | &#95; |  | Underscore
96 | 140 | 60 | 01100000 | ` | &#96; |  | Grave accent
97 | 141 | 61 | 01100001 | a | &#97; |  | Lowercase a
98 | 142 | 62 | 01100010 | b | &#98; |  | Lowercase b
99 | 143 | 63 | 01100011 | c | &#99; |  | Lowercase c
100 | 144 | 64 | 01100100 | d | &#100; |  | Lowercase d
101 | 145 | 65 | 01100101 | e | &#101; |  | Lowercase e
102 | 146 | 66 | 01100110 | f | &#102; |  | Lowercase f
103 | 147 | 67 | 01100111 | g | &#103; |  | Lowercase g
104 | 150 | 68 | 01101000 | h | &#104; |  | Lowercase h
105 | 151 | 69 | 01101001 | i | &#105; |  | Lowercase i
106 | 152 | 6A | 01101010 | j | &#106; |  | Lowercase j
107 | 153 | 6B | 01101011 | k | &#107; |  | Lowercase k
108 | 154 | 6C | 01101100 | l | &#108; |  | Lowercase l
109 | 155 | 6D | 01101101 | m | &#109; |  | Lowercase m
110 | 156 | 6E | 01101110 | n | &#110; |  | Lowercase n
111 | 157 | 6F | 01101111 | o | &#111; |  | Lowercase o
112 | 160 | 70 | 01110000 | p | &#112; |  | Lowercase p
113 | 161 | 71 | 01110001 | q | &#113; |  | Lowercase q
114 | 162 | 72 | 01110010 | r | &#114; |  | Lowercase r
115 | 163 | 73 | 01110011 | s | &#115; |  | Lowercase s
116 | 164 | 74 | 01110100 | t | &#116; |  | Lowercase t
117 | 165 | 75 | 01110101 | u | &#117; |  | Lowercase u
118 | 166 | 76 | 01110110 | v | &#118; |  | Lowercase v
119 | 167 | 77 | 01110111 | w | &#119; |  | Lowercase w
120 | 170 | 78 | 01111000 | x | &#120; |  | Lowercase x
121 | 171 | 79 | 01111001 | y | &#121; |  | Lowercase y
122 | 172 | 7A | 01111010 | z | &#122; |  | Lowercase z
123 | 173 | 7B | 01111011 | { | &#123; |  | Opening brace
124 | 174 | 7C | 01111100 | | | &#124; |  | Vertical bar
125 | 175 | 7D | 01111101 | } | &#125; |  | Closing brace
126 | 176 | 7E | 01111110 | ~ | &#126; |  | Equivalency sign - tilde
127 | 177 | 7F | 01111111 |  | &#127; |  | Delete

The extended ASCII codes (character code 128-255)

There are several different variations of the 8-bit ASCII table. The table below is according to ISO 8859-1, also called ISO Latin-1. Codes 128-159 contain the Microsoft� Windows Latin-1 extended characters.

DEC | OCT | HEX | BIN | Symbol | HTML Number | HTML Name | Description
128 | 200 | 80 | 10000000 | �� | &#128; | &euro; | Euro sign
129 | 201 | 81 | 10000001 |  |  |  |
130 | 202 | 82 | 10000010 | ‚ | &#130; | &sbquo; | Single low-9 quotation mark
131 | 203 | 83 | 10000011 | ƒ | &#131; | &fnof; | Latin small letter f with hook
132 | 204 | 84 | 10000100 | „ | &#132; | &bdquo; | Double low-9 quotation mark
133 | 205 | 85 | 10000101 | … | &#133; | &hellip; | Horizontal ellipsis
134 | 206 | 86 | 10000110 | † | &#134; | &dagger; | Dagger
135 | 207 | 87 | 10000111 | ‡ | &#135; | &Dagger; | Double dagger
136 | 210 | 88 | 10001000 | ˆ | &#136; | &circ; | Modifier letter circumflex accent
137 | 211 | 89 | 10001001 | ‰ | &#137; | &permil; | Per mille sign
138 | 212 | 8A | 10001010 | Š | &#138; | &Scaron; | Latin capital letter S with caron
139 | 213 | 8B | 10001011 | ‹ | &#139; | &lsaquo; | Single left-pointing angle quotation
140 | 214 | 8C | 10001100 | Œ | &#140; | &OElig; | Latin capital ligature OE
141 | 215 | 8D | 10001101 |  |  |  |
142 | 216 | 8E | 10001110 | Ž | &#142; |  | Latin captial letter Z with caron
143 | 217 | 8F | 10001111 |  |  |  |
144 | 220 | 90 | 10010000 |  |  |  |
145 | 221 | 91 | 10010001 | ‘ | &#145; | &lsquo; | Left single quotation mark
146 | 222 | 92 | 10010010 | ’ | &#146; | &rsquo; | Right single quotation mark
147 | 223 | 93 | 10010011 | “ | &#147; | &ldquo; | Left double quotation mark
148 | 224 | 94 | 10010100 | ” | &#148; | &rdquo; | Right double quotation mark
149 | 225 | 95 | 10010101 | • | &#149; | &bull; | Bullet
150 | 226 | 96 | 10010110 | – | &#150; | &ndash; | En dash
151 | 227 | 97 | 10010111 | — | &#151; | &mdash; | Em dash
152 | 230 | 98 | 10011000 | ˜ | &#152; | &tilde; | Small tilde
153 | 231 | 99 | 10011001 | ™ | &#153; | &trade; | Trade mark sign
154 | 232 | 9A | 10011010 | š | &#154; | &scaron; | Latin small letter S with caron
155 | 233 | 9B | 10011011 | › | &#155; | &rsaquo; | Single right-pointing angle quotation mark
156 | 234 | 9C | 10011100 | œ | &#156; | &oelig; | Latin small ligature oe
157 | 235 | 9D | 10011101 |  |  |  |
158 | 236 | 9E | 10011110 | ž | &#158; |  | Latin small letter z with caron
159 | 237 | 9F | 10011111 | Ÿ | &#159; | &Yuml; | Latin capital letter Y with diaeresis
160 | 240 | A0 | 10100000 |  | &#160; | &nbsp; | Non-breaking space
161 | 241 | A1 | 10100001 | � | &#161; | &iexcl; | Inverted exclamation mark
162 | 242 | A2 | 10100010 | � | &#162; | &cent; | Cent sign
163 | 243 | A3 | 10100011 | � | &#163; | &pound; | Pound sign
164 | 244 | A4 | 10100100 | � | &#164; | &curren; | Currency sign
165 | 245 | A5 | 10100101 | � | &#165; | &yen; | Yen sign
166 | 246 | A6 | 10100110 | � | &#166; | &brvbar; | Pipe, Broken vertical bar
167 | 247 | A7 | 10100111 | � | &#167; | &sect; | Section sign
168 | 250 | A8 | 10101000 | � | &#168; | &uml; | Spacing diaeresis - umlaut
169 | 251 | A9 | 10101001 | � | &#169; | &copy; | Copyright sign
170 | 252 | AA | 10101010 | � | &#170; | &ordf; | Feminine ordinal indicator
171 | 253 | AB | 10101011 | � | &#171; | &laquo; | Left double angle quotes
172 | 254 | AC | 10101100 | � | &#172; | &not; | Not sign
173 | 255 | AD | 10101101 | � | &#173; | &shy; | Soft hyphen
174 | 256 | AE | 10101110 | � | &#174; | &reg; | Registered trade mark sign
175 | 257 | AF | 10101111 | � | &#175; | &macr; | Spacing macron - overline
176 | 260 | B0 | 10110000 | � | &#176; | &deg; | Degree sign
177 | 261 | B1 | 10110001 | � | &#177; | &plusmn; | Plus-or-minus sign
178 | 262 | B2 | 10110010 | � | &#178; | &sup2; | Superscript two - squared
179 | 263 | B3 | 10110011 | � | &#179; | &sup3; | Superscript three - cubed
180 | 264 | B4 | 10110100 | � | &#180; | &acute; | Acute accent - spacing acute
181 | 265 | B5 | 10110101 | � | &#181; | &micro; | Micro sign
182 | 266 | B6 | 10110110 | � | &#182; | &para; | Pilcrow sign - paragraph sign
183 | 267 | B7 | 10110111 | � | &#183; | &middot; | Middle dot - Georgian comma
184 | 270 | B8 | 10111000 | � | &#184; | &cedil; | Spacing cedilla
185 | 271 | B9 | 10111001 | � | &#185; | &sup1; | Superscript one
186 | 272 | BA | 10111010 | � | &#186; | &ordm; | Masculine ordinal indicator
187 | 273 | BB | 10111011 | � | &#187; | &raquo; | Right double angle quotes
188 | 274 | BC | 10111100 | � | &#188; | &frac14; | Fraction one quarter
189 | 275 | BD | 10111101 | � | &#189; | &frac12; | Fraction one half
190 | 276 | BE | 10111110 | � | &#190; | &frac34; | Fraction three quarters
191 | 277 | BF | 10111111 | � | &#191; | &iquest; | Inverted question mark
192 | 300 | C0 | 11000000 | � | &#192; | &Agrave; | Latin capital letter A with grave
193 | 301 | C1 | 11000001 | � | &#193; | &Aacute; | Latin capital letter A with acute
194 | 302 | C2 | 11000010 | � | &#194; | &Acirc; | Latin capital letter A with circumflex
195 | 303 | C3 | 11000011 | � | &#195; | &Atilde; | Latin capital letter A with tilde
196 | 304 | C4 | 11000100 | � | &#196; | &Auml; | Latin capital letter A with diaeresis
197 | 305 | C5 | 11000101 | � | &#197; | &Aring; | Latin capital letter A with ring above
198 | 306 | C6 | 11000110 | � | &#198; | &AElig; | Latin capital letter AE
199 | 307 | C7 | 11000111 | � | &#199; | &Ccedil; | Latin capital letter C with cedilla
200 | 310 | C8 | 11001000 | � | &#200; | &Egrave; | Latin capital letter E with grave
201 | 311 | C9 | 11001001 | � | &#201; | &Eacute; | Latin capital letter E with acute
202 | 312 | CA | 11001010 | � | &#202; | &Ecirc; | Latin capital letter E with circumflex
203 | 313 | CB | 11001011 | � | &#203; | &Euml; | Latin capital letter E with diaeresis
204 | 314 | CC | 11001100 | � | &#204; | &Igrave; | Latin capital letter I with grave
205 | 315 | CD | 11001101 | � | &#205; | &Iacute; | Latin capital letter I with acute
206 | 316 | CE | 11001110 | � | &#206; | &Icirc; | Latin capital letter I with circumflex
207 | 317 | CF | 11001111 | � | &#207; | &Iuml; | Latin capital letter I with diaeresis
208 | 320 | D0 | 11010000 | � | &#208; | &ETH; | Latin capital letter ETH
209 | 321 | D1 | 11010001 | � | &#209; | &Ntilde; | Latin capital letter N with tilde
210 | 322 | D2 | 11010010 | � | &#210; | &Ograve; | Latin capital letter O with grave
211 | 323 | D3 | 11010011 | � | &#211; | &Oacute; | Latin capital letter O with acute
212 | 324 | D4 | 11010100 | � | &#212; | &Ocirc; | Latin capital letter O with circumflex
213 | 325 | D5 | 11010101 | � | &#213; | &Otilde; | Latin capital letter O with tilde
214 | 326 | D6 | 11010110 | � | &#214; | &Ouml; | Latin capital letter O with diaeresis
215 | 327 | D7 | 11010111 | � | &#215; | &times; | Multiplication sign
216 | 330 | D8 | 11011000 | � | &#216; | &Oslash; | Latin capital letter O with slash
217 | 331 | D9 | 11011001 | � | &#217; | &Ugrave; | Latin capital letter U with grave
218 | 332 | DA | 11011010 | � | &#218; | &Uacute; | Latin capital letter U with acute
219 | 333 | DB | 11011011 | � | &#219; | &Ucirc; | Latin capital letter U with circumflex
220 | 334 | DC | 11011100 | � | &#220; | &Uuml; | Latin capital letter U with diaeresis
221 | 335 | DD | 11011101 | � | &#221; | &Yacute; | Latin capital letter Y with acute
222 | 336 | DE | 11011110 | � | &#222; | &THORN; | Latin capital letter THORN
223 | 337 | DF | 11011111 | � | &#223; | &szlig; | Latin small letter sharp s - ess-zed
224 | 340 | E0 | 11100000 | � | &#224; | &agrave; | Latin small letter a with grave
225 | 341 | E1 | 11100001 | � | &#225; | &aacute; | Latin small letter a with acute
226 | 342 | E2 | 11100010 | � | &#226; | &acirc; | Latin small letter a with circumflex
227 | 343 | E3 | 11100011 | � | &#227; | &atilde; | Latin small letter a with tilde
228 | 344 | E4 | 11100100 | � | &#228; | &auml; | Latin small letter a with diaeresis
229 | 345 | E5 | 11100101 | � | &#229; | &aring; | Latin small letter a with ring above
230 | 346 | E6 | 11100110 | � | &#230; | &aelig; | Latin small letter ae
231 | 347 | E7 | 11100111 | � | &#231; | &ccedil; | Latin small letter c with cedilla
232 | 350 | E8 | 11101000 | � | &#232; | &egrave; | Latin small letter e with grave
233 | 351 | E9 | 11101001 | � | &#233; | &eacute; | Latin small letter e with acute
234 | 352 | EA | 11101010 | � | &#234; | &ecirc; | Latin small letter e with circumflex
235 | 353 | EB | 11101011 | � | &#235; | &euml; | Latin small letter e with diaeresis
236 | 354 | EC | 11101100 | � | &#236; | &igrave; | Latin small letter i with grave
237 | 355 | ED | 11101101 | � | &#237; | &iacute; | Latin small letter i with acute
238 | 356 | EE | 11101110 | � | &#238; | &icirc; | Latin small letter i with circumflex
239 | 357 | EF | 11101111 | � | &#239; | &iuml; | Latin small letter i with diaeresis
240 | 360 | F0 | 11110000 | � | &#240; | &eth; | Latin small letter eth
241 | 361 | F1 | 11110001 | � | &#241; | &ntilde; | Latin small letter n with tilde
242 | 362 | F2 | 11110010 | � | &#242; | &ograve; | Latin small letter o with grave
243 | 363 | F3 | 11110011 | � | &#243; | &oacute; | Latin small letter o with acute
244 | 364 | F4 | 11110100 | � | &#244; | &ocirc; | Latin small letter o with circumflex
245 | 365 | F5 | 11110101 | � | &#245; | &otilde; | Latin small letter o with tilde
246 | 366 | F6 | 11110110 | � | &#246; | &ouml; | Latin small letter o with diaeresis
247 | 367 | F7 | 11110111 | � | &#247; | &divide; | Division sign
248 | 370 | F8 | 11111000 | � | &#248; | &oslash; | Latin small letter o with slash
249 | 371 | F9 | 11111001 | � | &#249; | &ugrave; | Latin small letter u with grave
250 | 372 | FA | 11111010 | � | &#250; | &uacute; | Latin small letter u with acute
251 | 373 | FB | 11111011 | � | &#251; | &ucirc; | Latin small letter u with circumflex
252 | 374 | FC | 11111100 | � | &#252; | &uuml; | Latin small letter u with diaeresis
253 | 375 | FD | 11111101 | � | &#253; | &yacute; | Latin small letter y with acute
254 | 376 | FE | 11111110 | � | &#254; | &thorn; | Latin small letter thorn
255 | 377 | FF | 11111111 | � | &#255; | &yuml; | Latin small letter y with diaeresis

Non-Printing Characters |  |  |  |  | Printing Characters
Name | Ctrl char | Dec | Hex | Char | Dec | Hex | Char | Dec | Hex | Char | Dec | Hex | Char
null | Ctrl-@ | 0 | 00 | NUL | 32 | 20 | Space | 64 | 40 | @ | 96 | 60 | `
start of heading | Ctrl-A | 1 | 01 | SOH | 33 | 21 | ! | 65 | 41 | A | 97 | 61 | a
start of text | Ctrl-B | 2 | 02 | STX | 34 | 22 | " | 66 | 42 | B | 98 | 62 | b
end of text | Ctrl-C | 3 | 03 | ETX | 35 | 23 | # | 67 | 43 | C | 99 | 63 | c
end of xmit | Ctrl-D | 4 | 04 | EOT | 36 | 24 | $ | 68 | 44 | D | 100 | 64 | d
enquiry | Ctrl-E | 5 | 05 | ENQ | 37 | 25 | % | 69 | 45 | E | 101 | 65 | e
acknowledge | Ctrl-F | 6 | 06 | ACK | 38 | 26 | & | 70 | 46 | F | 102 | 66 | f
bell | Ctrl-G | 7 | 07 | BEL | 39 | 27 | ' | 71 | 47 | G | 103 | 67 | g
backspace | Ctrl-H | 8 | 08 | BS | 40 | 28 | ( | 72 | 48 | H | 104 | 68 | h
horizontal tab | Ctrl-I | 9 | 09 | HT | 41 | 29 | ) | 73 | 49 | I | 105 | 69 | i
line feed | Ctrl-J | 10 | 0A | LF | 42 | 2A | * | 74 | 4A | J | 106 | 6A | j
vertical tab | Ctrl-K | 11 | 0B | VT | 43 | 2B | + | 75 | 4B | K | 107 | 6B | k
form feed | Ctrl-L | 12 | 0C | FF | 44 | 2C | , | 76 | 4C | L | 108 | 6C | l
carriage feed | Ctrl-M | 13 | 0D | CR | 45 | 2D | - | 77 | 4D | M | 109 | 6D | m
shift out | Ctrl-N | 14 | 0E | SO | 46 | 2E | . | 78 | 4E | N | 110 | 6E | n
shift in | Ctrl-O | 15 | 0F | SI | 47 | 2F | / | 79 | 4F | O | 111 | 6F | o
data line escape | Ctrl-P | 16 | 10 | DLE | 48 | 30 | 0 | 80 | 50 | P | 112 | 70 | p
device control 1 | Ctrl-Q | 17 | 11 | DC1 | 49 | 31 | 1 | 81 | 51 | Q | 113 | 71 | q
device control 2 | Ctrl-R | 18 | 12 | DC2 | 50 | 32 | 2 | 82 | 52 | R | 114 | 72 | r
device control 3 | Ctrl-S | 19 | 13 | DC3 | 51 | 33 | 3 | 83 | 53 | S | 115 | 73 | s
device control 4 | Ctrl-T | 20 | 14 | DC4 | 52 | 34 | 4 | 84 | 54 | T | 116 | 74 | t
neg acknowledge | Ctrl-U | 21 | 15 | NAK | 53 | 35 | 5 | 85 | 55 | U | 117 | 75 | u
synchronous idel | Ctrl-V | 22 | 16 | SYN | 54 | 36 | 6 | 86 | 56 | V | 118 | 76 | v
end of xmit block | Ctrl-W | 23 | 17 | ETB | 55 | 37 | 7 | 87 | 57 | W | 119 | 77 | w
cancel | Ctrl-X | 24 | 18 | CAN | 56 | 38 | 8 | 88 | 58 | X | 120 | 78 | x
end of medium | Ctrl-Y | 25 | 19 | EM | 57 | 39 | 9 | 89 | 59 | Y | 121 | 79 | y
substitute | Ctrl-Z | 26 | 1A | SUB | 58 | 3A | : | 90 | 5A | Z | 122 | 7A | z
escape | Ctrl-[ | 27 | 1B | ESC | 59 | 3B | ; | 91 | 5B | [ | 123 | 7B | {
file separator | Ctrl-\ | 28 | 1C | FS | 60 | 3C | < | 92 | 5C | \ | 124 | 7C | |
group separator | Ctrl-] | 29 | 1D | GS | 61 | 3D | = | 93 | 5D | ] | 125 | 7D | }
record separator | Ctrl-^ | 30 | 1E | RS | 62 | 3E | > | 94 | 5E | ^ | 126 | 7E | ~
unit separator | Ctrl-_ | 31 | 1F | US | 63 | 3F | ? | 95 | 5F | _ | 127 | 7F | DEL
"http://www.physics.udel.edu/~watson/scen103/ascii.html"
Last updated Feb. 4, 1998.
Copyright George Watson, Univ. of Delaware, 1996.


Gesture

By using mouse movement+right button, or touch screen with finger gesture. you could achieve following ITTS main feature

通過鼠標移動+右鍵，或用手指手勢觸摸屏。 你可以實現以下ITTS主要功能

initial ( 執行 initial sectrion 內容, 達到腳本的重新設置)

TestScrip ( 顯示 腳本 編輯器)

Reset ( 初始化 ITTS)

Menu( 下拉選單)

UI Mode

( 1:MP Mode 大量生產模式)

( 2:Operator Mode 作業員模式)

( 3:Engineer Mode 工程時模式)

Change Page ( 換頁顯示. 主頁面, log 畫面,測試調適畫面, 依序 顯示)